Bentley Microstation V8i Manual
For Hydrography & Survey Use.

Tiffany Schnare
www.Geo-Tiff.com
MGeo 2014
Brian Pyke
May 30, 2013
Foreward

The following document was produced with the Marine Geomatics instructor, Brian Pyke in mind. Bentley Microstation is a CAD type of software; though it may not be as commonly used as AutoCAD in the Marine Industry it is slowly breaking through and becoming more mainstream. Thus it is a software program worth learning. This manual will focus on the basics of Microstation V8i and not get too into any Bentley extensions; other than Bentley Descartes which will be overviewed as it is the extension that deals with the Geospatial tools.

Enjoy exploring Bentley Microstation!
## Table of Contents

1. **Important to Remember!** ................................................................. 1
2. **Project Setup** ............................................................................... 2
   2.1 Creating/Opening a New .dgn File .............................................. 2
   2.2 Setting the Default Paths .......................................................... 3
   2.3 Setting the Master Units ............................................................. 4
3. **Multiple Views** ............................................................................ 5
   3.1 Opening/Closing the Views ....................................................... 5
4. **Tentative Snap** ............................................................................ 6
   4.1 Setting the Tentative Snap button .............................................. 6
   4.2 Using Tentative Snap ................................................................. 6
5. **Elements** .................................................................................... 7
   5.1 SmartLine .................................................................................. 7
   5.2 Length/Angle and AccuDraw .................................................... 7
   5.3 Partial Delete ............................................................................ 8
   5.4 Construct Circular Fillet ............................................................ 9
6. **Key-in Window** .......................................................................... 10
7. **Editing the Colour Table** ........................................................... 11
8. **Hatching/Filling** ......................................................................... 12
9. **Cells** .......................................................................................... 13
   1.1 Creating a cell Library ............................................................... 13
   1.2 Defining Objects for Cell ......................................................... 13
   1.3 Using Cells ............................................................................... 14
10. **Printer Driver** ........................................................................... 15
    1.4 Configuring the Printer Driver .................................................. 15
    1.5 Plotting .................................................................................... 15
1 Important to Remember!
The following is a list of the most useful tips and tricks I have found during my experience working with Bentley Microstation.

- Always keep an eye on the Status Bar; it will display information telling the user where they are in the command (tool) and what to do next.

- Each tool in Microstation has a dialogue/input box associated to it which will appear each time the tool is activated; remember to always check the box.

- In Microstation, pressing the scroll wheel is typically set to tentative snap; therefore, it cannot be used to pan; instead, use the hand tool 🕊 to pan.

- Snap modes allow you to precisely position a line, circle, etc.; they can be activated by left-clicking on the snap mode icon on the bottom menu bar.

- Each time a .dgn is opened or created, the first process that should be performed is setting the working units and angle readout.
  
  Settings > Design File

- If line weights/styles, point symbols, hatching, etc., do not appear in the display, then open the View Attributes drop-down menu; ensure that Fill and ensure that Line Weights/Styles, Fill, Patterns, Text, and Markers are active.

- In Microstation, clicking ESC will not exit a command; instead, click the right mouse button to exit or stop a tool.

- If a tool can’t be found, then search for it using the tool search window then open the tool by clicking the use it button.

Help > Tool Index
2 Project Setup

2.1 Creating/Opening a New .dgn File

This is the first step towards starting a project in Microstation.

- Microstation can open a multitude of file formats straight from the main menu; including AutoCAD and Shapefiles. The default Microstation design file is .dgn.

- The main menu will open each time Microstation is open by double-clicking on the official icon; it will not appear if Microstation is open by double-clicking on a .dgn file.

- When Microstation is first downloaded it will create a file path on your Local Disk drive and the main menu will default to it. It is highly recommended that this file structure NOT be used; instead create a folder (i.e. DGN) at the root of your working drive then create a new folder for each project.

1. Navigate to the project folder
2. Create a new .dgn file
3. Input file name
4. Make sure the Save as type is set to Microstation DGN Files (.dgn)
5. The seed file is the most important step in this process; this sets up the file for what the user will be using it for. (i.e. 3D/2D, surveying/engineering, etc.)
   a. Click the Browse button and select one of the default Bentley Seed files (User created seed files can also be created)
6. Save
7. The main menu will re-appear > Select the newly created file
   a. Open the User drop-down menu
   b. Create a new user or select your username
8. Open
### 2.2 Setting the Default Paths

In Section 2.1 the user created a specific folder (i.e. DGN) at the root of their working drive for project files this will make it so the next time Microstation is open it will default to that specific folder, saving the user much time searching for their directories.

1. Open the Workspace menu found at the top of the screen on the menu bar
2. Select Configuration
3. Scroll down to Primary Search Paths
4. Select Design Files > Edit
5. Delete the current path in the New Value input window
6. Make sure Edit Mode is set to Overwrite
7. Open Windows Explorer
8. Navigate to default folder (i.e. DGN)
9. Copy the FULL path
10. Paste the path into the New Value window
11. OK (x2)

All Primary Search Paths shown in blue have been modified by the user.
2.3 Setting the Master Units
This is an important step that should never be forgotten; do this as soon as any project file (.dgn) is open or created.

1. Open the Settings menu found at the top of the screen on the menu bar
2. Select Design File
3. Select Working Units
   a. Set the proper units and accuracy
4. Select Angle Readout
   a. Set the proper angle format (typically DD.MM.SS)
   b. Set the Direction Mode (typically Azimuth from North)
3 Multiple Views

Multiple views mean that Microstation has multiple display windows open. These display windows can be configured separately so each window can have its own colour, grid, settings and view.

To move from view window to view window they do not need to be clicked; simply move the mouse over the view you wish to modify and perform the modification; be that zooming, changing settings, etc.

![Figure 3 Multiple views open showing the same model at different angles.](image)

3.1 Opening/Closing the Views

The simplest way to open a view is by using the View menu on the bottom menu bar. Up to eight views are possible. To open a new view right-click on any grey number; to close a view right-click on any yellow number. Views automatically save; therefore if you open and set-up view 3 it will be there if you close it then open it back up.

![Figure 4 View menu with numbers 1-4 and 6 open.](image)
4 Tentative Snap
Tentative snap can be the most useful aid in Microstation if used correctly. The main use for tentative snap is when creating an object that are connected or related to an existing element. When tentative snap is turned on the user can click a specified button or key and the software will display the next point of entry (i.e. where the next segment of a line will snap/connect to an existing object).

4.1 Setting the Tentative Snap button
As default Tentative Snap is set to left-right mouse click but sometimes it can be difficult to press both buttons at the exact same moment therefore Tentative Snap is typically set to be the middle mouse button (wheel)

1. Workspace > Button Assignment
2. Click Remap Buttons
3. Select Tentative
4. Move the mouse pointer so it is in the Button Definition Area
5. Click the middle mouse button (wheel)
6. OK (x2)

![Figure 5 Remap Buttons Window.](image)

4.2 Using Tentative Snap
Now that tentative snap has been set to the middle mouse button it will be a breeze to use. As an example we will assume a user is creating a polygon and wants to make sure that the start and end match up exactly so it is closed.

Once the polygon is almost finished; just needs to be closed off, hover over the approximate start location then click the middle mouse button, if a cross with dotted lines appear then the tentative snap did not locate any locations on an object so try again. When the cross is solid white; meaning tentative snap found a location on an object to snap then accept it with a left mouse click.
5 Elements
Element tools are used to create the objects and features for plans/maps. Such as buildings, roads, site plans, etc.

5.1 SmartLine
This tool will create an object consisting of lines and arcs as one element, meaning all lines or arcs will automatically connect to one another. The following example will assume the user is creating a rectangle with user created rounded edges.

1. Open Place Smartline from the Drawing Toolbar
2. Make sure Join Elements is checked on
3. Vertex Type: Sharpe
4. Draw a line
5. Do not exit the tool > Change Segment Type to Arcs
6. Create an Arc
7. Do not exit the tool > Change Segment Type to Lines
8. Do this until the end of the drawing; do not stop otherwise the lines will not be joined

5.2 Length/Angle and AccuDraw
While in any drawing tool the user can input the length of the line using the XY location of the next segment. This can be done by simply typing the X coordinate then the Y coordinate. Keep an eye on the AccuDraw menu at the bottom of the screen.

![Figure 6 XY AccuDraw toolbar.](image)

The AccuDraw toolbar can also process distance and angle values; to change the input values press the space bar.

![Figure 7 Distance/Angle AccuDraw toolbar.](image)
5.3 Partial Delete
This tool will delete a portion of an element not the entire object.

This section along with Section 5.4 – Construct Circular Fillet will guide the user through creating a cul-de-sac.

1. Left-click and hold on 
2. Open ‘Modify’ as Toolbox
3. Open the Partial Delete tool
4. Select the start point of the break
5. Select the end point of the break

![Figure 8 Before the break and after the break]
5.4 Construct Circular Fillet

Cul-de-sac creation continued from Section 5.3 – Partial Delet.

This tool will turn the straight connection between two elements into an arc.

1. Left-click and hold on
2. Open ‘Modify’ as Toolbox
3. Select the Construct Circular Fillet tool
4. Change the Radius value > Truncate: Both
5. Select the first line and the circle
6. The intersection will automatically connect and become an arc

![Figure 9](image)

Figure 9 A cul-de-sac with one circular fillet connection (left) and straight connection (right).
6  Key-in Window
The key-in window is similar to the command line in AutoCAD. The key-in window can process coordinates, open tools, and create elements.

It is not displayed at all times to start an input into the key-in window make sure no tools are active (click 1), click Enter.

To create an element/start a process:

1. Make sure no tools are active > Click Enter
2. Start a command/tool (i.e. line or place circle radius)
3. Input coordinates (i.e. xy=1000,2000)
4. From here there are number of options; for this example we will assume the user is placing a line with multiple segments.
   a. Input the location for the next segment (i.e. di=36,s45d54°08.45"w or xy=2000,4000)

See Appendix A for an example of multiple commands inputted into the key-in menu to create the start of a survey plan.

Figure 10 Example Survey Plan using the values from Appendix A; also showing the use of the partial delete and circular fillet tools.
7 Editing the Colour Table
This process will change the default colours shown in the colour table. Mainly used during large projects, when more than one user will be working on the same file, or when many maps will be created in a series and the colours need to be consistent.

1. Settings > Colour Table
2. Edit > Interpolate Colours
3. Double click on any color
   a. Input RGB colours or select a colour using the colour ramp > OK

A blended ramp can be created from two colours by selecting the two colour icons then clicking Blend. Note that these colours need to be on the same line/column and at least one block separating them.

4. File > Save as
5. Input name > Save

The colour table can be reverted at any time; File > Revert
8 Hatching/Filling
Hatching is used to fill an object and express how the feature is composed or to
distinguish it from surrounding features. (i.e. a gravel parking lot will be filled
differently than a paved parking lot)

There are two default methods for filling objects; Hatch and Crosshatch Area.

1. Open either the Hatch or Crosshatch tool from the Drawing toolbar
2. Click INSIDE the object that you want to hatch

Microstation lacks in hatch patterns therefore the user must create their own
'Cells' to use for hatching. (see Section 10 - Cells) Once the cells are created
open the Pattern Area tool, select Pattern Definition: From Cell, then select the
object to fill.
9  Cells
Cells are blocks of objects grouped together to form one element. They are used as symbols for points and hatching or to ensure consistency from one project to another.

The following process need to be done in a blank .dgn; **NOT** the main project file.

1.1 Creating a cell Library
A cell library is a group of usually similar cells; as many libraries as needed can be created.

1. From the main Microstation menu select Element > Cells
2. From the menu bar select File > New
3. Input Cell Library name
4. Save

1.2 Defining Objects for Cell
The create cell button will remain disabled until the cell objects are defined.

1. Move the Cells dialogue box (do not close)
2. Select all the objects for a single cell
3. On the Navigation task menu left-click and hold Place Active Cell
4. Choose Define Cell Origin or key 4
5. Select the centre of the objects
6. In the Cell dialogue box click Create...
7. Input Cell name and description
1.3 Using Cells

Once the cells are created, the main project .dgn can be opened and the cells can be used.

1. Load the Cell Library
   a. Element > Cell
   b. File > Attach File...
   c. Select Cell library file or folder containing multiple Cell libraries

2. Select the cell you want to use

3. Move the Cell dialogue box out of the way

4. On the Task menu select Place Active Cell or key S

5. The angle, size, and active cell can be modified in the Place Active Cell window

6. Select the location on the map for the cell to be placed
10 Printer Driver
This is the final step in map creation therefore it is an important step; take you time going through the following processes to ensure an adequate output.

1.4 Configuring the Printer Driver
The printer driver needs to be configured for each project otherwise the output map will not contain the proper line weights, styles, etc.

1. File > Print
2. In the print window select file > Select Bentley Driver > Open Printer.pltcfg
3. In the print window select file > Edit Printer Driver > Configuration
4. Go through the following tabs and input the correction information:
   a. Color Maps
   b. Weight Maps
   c. Line Styles
5. File > Save

1.5 Plotting
1. Open the view attributes drop-down menu; turn on everything as you want it to appear on the final plot (i.e. line weights)
2. Using the fence tool create a fence around the entire drawing with little to no buffer surrounding it
3. On the main Microstation toolbar open File > Print
   a. Area: Fence
   b. Check on Auto-Center
   c. Input Scale (optional)
4. Preview 
5. Print
Appendix A: Survey Plan Key-In Values - Example Only

place line
xy=63117.3934,5711391.9986
di=10.0516,N89d10'58.1563"E
di=15.8483,N89d15'57.8933"E
di=11.9521,N89d13'58.6915"E
di=6.3624,N44d16'03.6589"E
di=30.4713,N00d42'04.9575"W
di=16.4495,S89d14'01.2724"W
di=15.8216,S89d10'53.5603"W
di=15.8196,S89d10'53.1878"W
di=19.0247,S89d14'06.0628"W
di=35.9902,S89d14'14.7029"W
di=38.8528,S05d44'24.8424"W
di=32.1109,S03d09'48.2406"E
di=6.1579,S44d18'09.3214"E
di=36.7191,N45d54'04.0243"E
reset
place line
xy=63086.5659,5711374.1223
di=36.3082,S45d54'08.4054"W
di=10.4723,S44d17'59.0958"E
di=25.5713,N89d13'37.0582"E
di=18.8559,N89d11'41.0621"E
di=15.8266,N89d11'33.5856"E
di=15.8523,N89d16'24.5812"E
di=16.4495,N89d13'48.7342"E
di=30.4713,N00d42'18.4948"W
di=6.3546,N45d44'22.5182"W
di=11.9521,S89d13'58.6915"W
di=15.8205,S89d12'11.5929"W
di=10.0330,N89d11'14.9442"W
reset
place circle radius
xy=63097.6686,5711384.2084
radius=15.0000
reset